Информатика, вопрос задал borismachkalan , 7 лет назад

ЗАДАЧА НА ПИТОНЕ ДАЮ 25 БАЛЛОВ . Рабочие поднимают на грузовом лифте ящики.

Если ящик весит больше 180 кг, то лифт отказывается его поднимать. Напишите программу, которая будет подсчитывать, сколько ящиков было поднято на грузовом лифте и общую массу ящиков, которые лифт поднять не смог.

С клавиатуры вводятся массы всех ящиков (в кг), символ окончания ввода - это ноль.

Формат входных данных
Последовательность целых положительных чисел, на конце ноль.

Формат выходных данных
Ответ в формате:

Было поднято N ящиков, но еще K кг груза ожидают внизу.

Ответы на вопрос

Ответил Makson6666
0

boxes = []

count = 0

waiting = 0

for i in range(10):

  new_box = (int(input(f"Введите массу {i} ящика")))

  if new_box > 180:

     waiting = waiting + new_box

  else:

     count = count + 1

     boxes.append(new_box)

print(f"Было поднято {count} ящиков, но ещё {waiting} кг груза ожидают внизу.")

Приложения:

Makson6666: Тут табуляция навернулась, если что
Makson6666: Я прикрепил фото с табуляцией(отступами)
borismachkalan: не то
Новые вопросы