Информатика, вопрос задал bossrjk , 7 лет назад

Задача 1 (в тетради для дз)

Написать программу, обрабатывающую поток водимых с клавиатуры целых чисел (пока не будет введен 0) и выводящую на экран количество введенных чисел, количество положительных, а также сумму и среднее арифметическое только положительных. Задачу можно решать через любой оператор цикла (кроме for).

Формат вывода:
Введено чисел_
Из них положительных_
Сумма положительных чисел_
Среднее арифметическое положительных чисел_

Ответы на вопрос

Ответил 13nisa13
0

var a,k,p,s: integer;

begin  

repeat

write('Введите число: ');

readln(a);

if a<>0 then k:=k+1;

if a>0 then

begin

p:=p+1;

s:=s+a

end

until a=0;

writeln;

writeln ('Введено чисел_',k);

writeln ('Из них положительных_',p);

writeln ('Сумма положительных чисел_',s);

writeln ('Среднее арифметическое положительных чисел_',s/p:0:3);

end.

Новые вопросы