Информатика, вопрос задал asdrghjkliu , 7 лет назад

СРОЧНО!!!
НАПИСАТЬ ПРОГРАММУ НА PYTHON
Напишите программу, которая в последовательности натуральных чисел определяет количество трёхзначных чисел, кратных 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: количество трёхзначных чисел, кратных 4.

Ответы на вопрос

Ответил ssafinurov
0

Ответ:

import random

def masgen(n):

   mlist=[  random.randint(-10,90) for i in range(n)] # генерируем список

   print(mlist)# выводим

   for i in mlist:

       if i %2==0 and i%9==0: # проверяем кратность

           mlist1.append(i) # выводим результат в список

   print(len(mlist1))# печатаем его длинну

 

if __name__ == '__main__':

   mlist1=[]

   n=int(input())

   masgen(n)

Объяснение:

Новые вопросы