Составить программу на Паскале. На турнире соревновались два спортсмена – А и В. Всего было проведено N туров. Результаты каждого спортсмена по турам записаны в два массива А и В. Победителем в каждом туре считается тот, кто в этом туре набрал больше очков. Победителем соревнования считается тот, кто победил в большем количестве туров. Определить, кто победил в соревновании. Если А и В победили одинаковое число раз, то засчитывается ничья.
Ответы на вопрос
var
a: array of real;
b: array of real;
a_sum, b_sum, i, n: integer;
a_values, b_values: real;
begin
randomize;
writeln('Введите количество туров: ');
readln(n);
a := new real[n];
b := new real[n];
a_sum := 0;
b_sum := 0;
writeln('Введите результаты первого спортсмена: ');
for i := 0 to n - 1 do
begin
readln(a_values);
a[i] := a_values;
end;
writeln('Введите результаты второго спортсмена: ');
for i := 0 to n - 1 do
begin
readln(b_values);
b[i] := b_values;
end;
writeln('Результаты первого спортсмена: ');
for i := 0 to n - 1 do
write(a[i], ' ');
writeln(#10);
writeln('Результаты второго спортсмена: ');
for i := 0 to n - 1 do
write(b[i], ' ');
writeln(#10);
for i := 0 to n - 1 do
if (a[i] > b[i]) then inc(a_sum) else
if a[i] = b[i] then begin inc(a_sum);inc(b_sum); end else
if (a[i] < b[i]) then inc(b_sum);
writeln('Первый спортсмен победил в ', a_sum, ' турах.', #10, 'Второй спортсмен победил в ', b_sum, ' турах.');
if (a_sum = b_sum) then writeln('В общем зачёте ничья!') else
if (a_sum > b_sum) then writeln('В общем зачёте побеждает первый спортсмен!') else
if (a_sum < b_sum) then writeln('В общем зачёте побеждает второй спортсмен!');
end.