Информатика, вопрос задал анджелаaнджелика , 8 лет назад

Составить программу , которая сложить две дроби!
Нужно сначала привести к общему знаменателю срочно!
Паскаль !

Ответы на вопрос

Ответил smnoregrets
0
Программа и скриншот как она работает в приложениях.
Приложения:
Ответил smnoregrets
0
с минусами не проверял. Подумал что речь идет только о простых дробях
Ответил Аноним
0
Простая дробь - это целочисленные числитель a и знаменатель b при условии |a| < |b|
Ответил smnoregrets
0
сохранил себе ваше решение. Спасибо!
Ответил Аноним
0
В NumLibABC есть класс Fraction для работы с простыми дробями. А количество цифр там произвольное (практически бесконечное).
Ответил Аноним
0
Поскольку это мой код, я с полным правом взял алгоритм оттуда и упростил его.
Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1607 от 31.12.2017
// Внимание! Если программа не работает, обновите версию!

function GCD(a,b:integer):integer; // НОД
begin
  while b<>0 do begin a:=a mod b; Swap(a,b) end;
  Result:=a
end;

procedure RedFrac(var a,b:integer); // сокращение дроби
begin
  var (sgna,sgnb):=(Sign(a),Sign(b)); // мы должны учитывать знак!
  (a,b):=(Abs(a),Abs(b));
  var d:=Gcd(a,b);
  (a,b):=((a div d)*sgna,(b div d)*sgnb)
end;

begin
  var (a,b):=ReadInteger2('Числитель и знаменатель 1-й дроби:');
  var (c,d):=ReadInteger2('Числитель и знаменатель 2-й дроби:');
  var (p,q):=(a*d+b*c,b*d);
  RedFrac(p,q);
  Writeln('Результат: ',p,'/',q)
end.

Пример
Числитель и знаменатель 1-й дроби: -135 36
Числитель и знаменатель 2-й дроби: 31 60
Результат: -97/30
Приложения:
Новые вопросы