Информатика, вопрос задал Аноним , 1 год назад

Составить программу, которая определяет возможность существования
треугольника по трем введенным сторонам. Треугольник существует только
тогда, когда сумма любых двух его сторон больше третьей.

Ответы на вопрос

Ответил BlazBlaz
6

var a, b, c: integer;

 

begin

   write (' Длины сторон: ');

   readln (a,b,c);

 

   if (a < b+c) and (b < a+c) and (c < a+b) then

       writeln ('Треугольник существует.')

   else

       writeln ('Треугольник не существует.');

 

readln

end.

Новые вопросы