Информатика, вопрос задал Аноним , 2 года назад

РЕШИТЕ ПЛИЗ ЗАДАЧУ НА ЯЗЫКЕ С++!!!!!!!!!!

Дан массив a из 15 целых чисел. Требуется переставить в обратном порядке элементы, расположенные между k-м и s-м элементами, т.е. с (k+1)-го по (s−1)-й.

Формат входных данных
На первой строке через пробел записаны 15 целых чисел ai (|ai|≤1000) — элементы массива. На второй строке через пробел записаны два целых числа k и s (1≤k
Формат выходных данных
Требуется вывести 15 чисел — изменённый массив.

входные данные
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
2 10
выходные данные
1 2 9 8 7 6 5 4 3 10 11 12 13 14 15

Ответы на вопрос

Ответил serezhaKovalev2004
0

int main() {

int t=0;

int a[15]={};

//ввод массива

for (int i=0; i<15; i++){

cin >> a[i];

}

int k, s;

cin>>k>>s;

   // изменение массива

   for( int i = k; i < s - 1; i++, s-- )

   {

       t = a[i];

       a[i] = a[s - 2];

       a[s - 2] = t;

   }

//вывод массива

for(int i=0;i<15;i++){

cout<<a[i]<<" ";}

return 0;

}


serezhaKovalev2004: Не за что!
serezhaKovalev2004: Прости, но я уже лёг спать
serezhaKovalev2004: сладких снов)
serezhaKovalev2004: Я мог ошибиться в решении, перепроверь)
Новые вопросы