Даю 20 баллов за решение задачи на языке с++!!!!!!!!
Дан массив a из n элементов. Требуется найти минимум массива и вставить его в начало, порядок других элементов сохранить. Если минимальных элементов несколько, переместить первый найденный минимальный элемент массива.
Формат входных данных
С клавиатуры вводится натуральное число n (n≤100) — размер массива. Во второй строке вводятся n элементов массива через пробел. Все элементы не превосходят по модулю 100.
Формат выходных данных
Необxодимо вывести измененный массив.
входные данные
5
4 5 3 1 2
выходные данные
1 4 5 3 2
Ответы на вопрос
Ответил ssroman72
1
Ответ:
Объяснение:
#include <iostream>
using namespace std;
int main()
{
int a[5];
int k;
int i;
setlocale(LC_ALL, "Russian");
cout << "введите через пробел пять элементов массива a:";
cin>>a[1]>>a[2]>> a[3]>>a[4]>>a[5];
cout <<"Входные данные:";
cout << a[1]<<" "<< a[2]<<" "<< a[3]<<" "<<a[4]<<" "<<a[5]<<endl;
int min=a[1];
for (int i=2; i<=5; i++)
{
if (min>a[i])
{
min=a[i];
k=i;
}
}
cout<<"Минимальный элемент массива:";
cout << min<<endl;
int x=a[k];
for ( i=k; i>1; i--)
{ a[i]=a[i-1];
}
if ( i<=0)
a[1]=min;
else
a[1]=x;
cout <<"Выходные данные:";
cout << a[1]<<" "<< a[2]<<" "<< a[3]<<" "<<a[4]<<" "<<a[5]<<endl;
return 0;
}
Приложения:

ssroman72:
Увеличите картинку с результатами
Новые вопросы