Информатика, вопрос задал Masha2019 , 2 года назад

Решить задачу в Turbo Pascal.
Задача: Поиск букв в слове. Напишите программу для проверки, есть ли в данном слове буква «а». Если есть, то найдите номер первой из них.

Ответы на вопрос

Ответил danyamare
1
beginvar a:string;var i:integer;read(a);for i:=1 to length(a) dobegin if a[i] = 'a' thenbeginwriteln('Найдена буква а, ее позиция: ' , i);break;end;end;
end.

Masha2019: Вы не могли бы написать так, как нужно вводить в самом турбо паскале? у меня с программированием все очень плохо, не понимаю как это все и в каком порядке мне это нужно вводить
Masha2019: var a:string;
var i:integer;
begin
writeln('‚Введите слово;');
read(a);
for i:=1 to length(a) do begin
if (a[i]='а') or (a[i]='А') then begin
writeln('Найдена буква а, ее позиция: ' , i);
break;
end;
end;
end.
Masha2019: Вроде до меня дошло, спасибо
danyamare: извини ,у меня не получалось написать ответ так. всё правильно
Новые вопросы