PascalABC.net Помогите пж Если можно то сделайте по простому
Теперь, когда торговля в городе процветает, пришло время подумать о долгосрочных перспективах. В вашу казну недавно пришло n поступлений по k сентиннеалей. Вы решили инвестировать их в промышленность и рассчитываете на ежегодное увеличение своего вложения в m раз.
Рассчитайте, сколько сентиннеалей у вас будет через х лет.
Формат входных данных
В первой строке вводится целое число денежных поступлений n (1 <= n <= 100)
Во второй строке вводится n целых чисел k в строчку, где k - каждое из постулений (1<= k <=10000)
В третьей строке вводятся целые числа x и m - количество лет, в течении которых будет накапливаться итоговая сумма (1<= x <=10), и число раз, в которые будет увеличиваться сумма каждый год (2<= m <=12)
Формат выходных данных
Выводится целое число, равное итоговой сумме накоплений.
Примеры
входные данные
5
2 2 5 4 2
1 2
выходные данные
30
Ответы на вопрос
Ответил petyaGavrikov
0
// PascalABC.NET 3.3
begin
var n:=ReadInteger('n =');
var k:=ReadSeqInteger(n);
var s:=k.Sum;
var (x,m):=ReadInteger2;
writeln(s*power(m,x)); // s*(m**x)
end.
Пример:
5
2 2 5 4 2
3 2
120
begin
var n:=ReadInteger('n =');
var k:=ReadSeqInteger(n);
var s:=k.Sum;
var (x,m):=ReadInteger2;
writeln(s*power(m,x)); // s*(m**x)
end.
Пример:
5
2 2 5 4 2
3 2
120
Новые вопросы
ОБЖ,
1 год назад