Информатика, вопрос задал Nata3v , 9 лет назад

решить на Паскале или Питоне, или .хотя бы алгоритм Задача: Для настольной игры используются карточки с номерами от 1 до N. Одна карточка потерялась. Найдите ее, зная номера оставшихся карточек. Входные данные:Дано число N, далее N-1 номер оставшихся карточек (различные числа от 1 до N).

Ответы на вопрос

Ответил Аноним
0
var n, tmp, sum, i:integer;begin     readln(n);     sum := (n * (n + 1)) div 2;     for i := 1 to n - 1 do     begin          read(tmp);          sum := sum - tmp;     end;     writeln(sum);end.
Ответил Аноним
0
Джава - интерпретатор, с ним соревноваться в эффективности кода смешно.
Ответил Аноним
0
А из компиляторов может только с fpc, но это тоже запара будет хорошая.
Ответил Nata3v
0
Fortran ещё используют? удивительно!
Ответил Аноним
0
Конечно, но в узких кругах. Хотя наш препод обожает асм и фортран.
Ответил Аноним
0
Майкрософт до сих пор втихую компилирует не своим компилятором, а использует в ответственных случаях Watcom C )))
Новые вопросы