Информатика, вопрос задал LuminițaB , 9 лет назад

 
Пожалуйста, срочно помогите)
Напишите программу, определяющую, сколько слов в данной строке текста.(Pascal) 

На вход программы поступает строка текста, в которой могут встречаться:
— прописные и строчные (т.е. большие и маленькие) латинские буквы;
— пробелы;
— знаки препинания: точка, запятая, восклицательный и вопросительный знак;
— символ –, обозначающий в некоторых случаях тире, а в некоторых — дефис.
Слово — это последовательность подряд идущих латинских букв и знаков дефис, ограниченная с обоих концов. В качестве ограничителей могут выступать начало строки, конец строки, пробел, знак препинания, тире. Тире отличается от дефиса тем, что слева и справа от знака дефис пишутся буквы, а хотя бы с одной стороны от тире идет либо начало строки, либо конец строки, либо пробел, либо какой-либо знак препинания, либо еще одно тире.

Ответы на вопрос

Ответил 140201
0
Получилась очень громоздкая конструкция из логический условий, но по-другому никак не придумалось

var t: string; n: integer; i,x,y: byte;
begin
  writeln ('Введите строку');
  readln (t);
  n:=length(t);
  t:=t+'.'; //пририсовываем к строке лишний символ "не буква", иначе программа может не посчитать последнее слово в случае, если строка кончается буквой.
  x:=0;   // переменная для обозначения конца каждой группы из букв, идущих подряд 
  y:=0;   // переменная для подсчета количества групп из букв, идущих подряд  
  for i:=1 to n do 
    begin
      // определяем, является ли текущий символ буквой:
      if ((ord(t[i])>64) and (ord(t[i])<91)) or ((ord(t[i])>96) and (ord(t[i])<123)) or ((ord(t[i])>191) and (ord(t[i])<256))
        then x:=1    //если да, то х=1
        else 
          begin
            if x=1 then begin y:=y+1; x:=0 end;  // если текущий символ не буква, то проверяем "х" - если х=1, значит слово кончилось и "у" увеличиваем на 1, а "х" соответственно снова обнуляем. теперь при следующем символе "небуква" наш "у" не увеличится
                 //В следующем длинном условии проверяем исключение - является ли текущий символ тире или дефисом. если дефис, то количество уже посчитанных слов уменьшим на 1, т.к. дефис стоит в середине слова и значит предыдущее прибавление 1 было неправильным.
            if (t[i]='-') and (((ord(t[i-1])>64) and (ord(t[i-1])<91)) or ((ord(t[i-1])>96) and (ord(t[i-1])<123)) or ((ord(t[i-1])>191) and (ord(t[i-1])<256))) and (((ord(t[i+1])>64) and (ord(t[i+1])<91)) or ((ord(t[i+1])>96) and (ord(t[i+1])<123)) or ((ord(t[i+1])>191) and (ord(t[i+1])<256)))
              then y:=y-1
          end
    end;
  
  writeln('В данной строке ',y,' слов')
end.

Результат работы программы:

Введите строку
Ali-Baba,- это не имя атамана разбойников, это китайский магазин.
В данной строке 9 слов


Новые вопросы
Математика, 2 года назад