ПОМОГИТЕ! В Паскале написать программу: автоматический массив, состоящий из 10 элементов. Нужно убрать из него все отрицательные числа, заменив их 0. И при этом все нули (если они уже есть или замененные отрицательные числа) переставить в конец,
Ответы на вопрос
Ответил informator
0
program noname;
uses crt;
var
a,b:array[1..1000] of integer;
i,j,k:integer;
begin
clrscr;
for i:=1 to 10 do
begin
write('a[',i,']=');
readln(a[i]);
b[i]:=0;
if a[i]<0 then a[i]:=0;
end;
j:=1;
for i:=1 to 10 do
if a[i]<>0 then begin b[j]:=a[i]; j:=j+1; end;
for i:=1 to 10 do
write(b[i],' ');
end.
Новые вопросы