Помогите пожалуйста, очень прошу.!!!!!!!!
Написать программу в Pascal:
В одномерном МАССИВЕ введённом с клавиатуры определить сколько элементов имеет отрицательный индекс, сколько ненулевых элементов в массиве, рассчитать среднее значение положительных элементов.( Все эти условия должны быть в одной программе, и с помощью массива)Если поможете, я буду очень благодарен. СПАСИБО)))))
Ответы на вопрос
Ответил kornickevg
0
program masss;
var
a:array[-5..5] of integer;
i,oi,n0,s: integer;
begin
oi:=0;n0:=0; s:=0;
for i:=-5 to 5 do
begin
read(a[i]);
if i<0 then inc(oi);
if a[i]<>0 then inc(n0);
if a[i]>0 then s:=s+a[i];
end;
writeln('элементы с отрицательным индексом》',oi);
writeln('ненулевых элементов в массиве》',n0);
writeln('среднее значение положительных элементов》',s/11);
readln;
end.
Новые вопросы