Помогите пожалуйста!!!! Не могу написать программу на языке паскаль. Даны три целых двузначных числа. Из наибольшего из них вычесть наименьшее и сравнить результат с оставшимся числом. Если полученное число будет больше вывести YES в противном случае NO.
Ответы на вопрос
Ответил Аноним
0
var
a,b,c,max,mid,min,t:integer;
begin
Writeln('Введите через пробел три целых двухзначных числа');
Readln(a,b,c);
if a>b then begin max:=a; min:=b end
else begin max:=b; min:=a end;
if max<c then begin mid:=max; max:=c end
else mid:=c;
if min>mid then begin t:=mid; mid:=min; min:=t end;
if (max-min)>mid then Writeln('YES')
else Writeln('NO')
end.
Тестовое решение:
Введите через пробел три целых двухзначных числа
37 93 74
NO
a,b,c,max,mid,min,t:integer;
begin
Writeln('Введите через пробел три целых двухзначных числа');
Readln(a,b,c);
if a>b then begin max:=a; min:=b end
else begin max:=b; min:=a end;
if max<c then begin mid:=max; max:=c end
else mid:=c;
if min>mid then begin t:=mid; mid:=min; min:=t end;
if (max-min)>mid then Writeln('YES')
else Writeln('NO')
end.
Тестовое решение:
Введите через пробел три целых двухзначных числа
37 93 74
NO
Ответил oikatrin24rus
0
Спасибо огромное= )
Ответил Аноним
0
Кнопочки и восторга на 4 из 5 звездочек вполне достаточно.
Новые вопросы
Математика,
2 года назад
Математика,
2 года назад
Математика,
9 лет назад
Математика,
9 лет назад
Алгебра,
10 лет назад
Алгебра,
10 лет назад