Информатика, вопрос задал Emo4ka1998 , 10 лет назад

Помогите!!!!очень нужно))паскаль.   паскаль. 1)известны оценки по информатике каждого из 20 учеников класса. В начале списка перечислены все пятерки, затем все остальные оценки. Сколько учеников имеют по информатике оценку пять?Условный оператор не использовать. 
2)Составить программу, которая находит минимальное число большее 200, которое нацело делится на 17. Использовать цикл с предусловием While.всю программу напишите, пожалуйста)))

Ответы на вопрос

Ответил emblerik
0

1) (Если оценки ≤ 5)
var

  count, a, i : integer;

begin

  count := 0;

  for i := 1 to 20 do

  begin

    read (a);

    count := count + a div 5; 

  end;

  writeln (count);

end;

 

2)

var

  c : integer;

begin

  c := 200;

  while c mod 17 <> 0 do c := c + 1;

  writeln (c);

end;

 

  

Новые вопросы