Информатика, вопрос задал maksimmakaka , 2 года назад

PascalABC.net help please    Если можно то сделайте по простому

После ярмарки прошло много месяцев, городок разрастался и прибыли от торговли кроликами уже стало не хватать. Вы поняли, что скоро для города начнется эра торговли, и чтобы быть готовым к ней, вы пошли получать дополнительное математическое образование. Теперь вам предстоит решить задачу итогового экзамена.

Задача состоит в следующем: Вводится число Х, вы должны найти все делители данного числа и выписать их в строку через пробел.

Формат входных данных

Вводится целое число Х (1 <= X <= 1000000)
Формат выходных данных

Выводится строка с числами, являющимися делителями Х
Примеры

входные данные
6

выходные данные
1 2 3 6

Ответы на вопрос

Ответил petyaGavrikov
0
// PascalABC.NET 3.3

begin
  var x:=ReadInteger;
  Range(1,x+1,1).ForEach(y->if x mod y=0 then write(y,' '));
end.

Пример:
20

Новые вопросы