PascalABC.net Если можно то сделайте по простому
После ярмарки к вам подошел мужчина с немного странными взглядом. Он сказал, что он ремесленник и изготавливает детские игрушки. Более того, за изготовление игрушки он просит от казны всего один сентенниаль (местная валюта). Но за каждую следущую игрушку он хочет на один сентенниаль больше, чем за предыдущую.
Рассчитайте сколько сентенниалей предстоит заплатить за Х игрушек.
Формат входных данных
Вводится целое число Х (1 <= X <= 1000)
Формат выходных данных
Выводится целое число сентиннелей, которые предстоит заплатить казне за Х игрушек
Примеры
входные данные
5
выходные данные
15
Ответы на вопрос
Ответил petyaGavrikov
0
// PascalABC.NET 3.3
begin
var x:=ReadInteger;
writeln((1+x)*x div 2);
end.
Пример:
6
21
begin
var x:=ReadInteger;
writeln((1+x)*x div 2);
end.
Пример:
6
21
Новые вопросы