напишите программу находящую среднее арифметическое четных чисел, вводимых с клавиатуры. задачу решить с помощью цикла с параметром
Ответы на вопрос
Ответил NewLifer
1
program prl;
uses crt;
var i,n,summa:integer;
srednee:real;
a:arra[1..100] of integer;
begin
write('Введите кол-во четных элементов');
readln(n);
summa:=0;
for i:=1 to n do begin
write('Введите ',i,' элемент:');
readln(A[i]);
summa:=summa+A[i];
end;
srednee:=summa/(n div 2);
writeln('Среднее арифметическое',srednee:3:2);//
readln;
end.
uses crt;
var i,n,summa:integer;
srednee:real;
a:arra[1..100] of integer;
begin
write('Введите кол-во четных элементов');
readln(n);
summa:=0;
for i:=1 to n do begin
write('Введите ',i,' элемент:');
readln(A[i]);
summa:=summa+A[i];
end;
srednee:=summa/(n div 2);
writeln('Среднее арифметическое',srednee:3:2);//
readln;
end.
Новые вопросы