Информатика, вопрос задал Blin4iIk , 7 лет назад

Напишите программу на Pascal для решения системы уравнений 30 БАЛЛОВ

Приложения:

Ответы на вопрос

Ответил csharp
0

Если используете PascalABC.NET, уберите следующую строку:

  1. uses Math;

Задание 1

  1. uses Math;
  2. var
  3.  x, y: real;
  4. begin
  5.  Write('Введите x: ');
  6.  Readln(x);
  7.  
  8.  if (x < 6) then
  9.    y := Power(x, 4.0)
  10.  else y := 5 * x;
  11.  
  12.  Writeln('y = ', y);
  13. end.

Задание 2

  1. uses Math;
  2. var
  3.  x, y: real;
  4. begin
  5.  Write('Введите x: ');
  6.  Readln(x);
  7.  
  8.  if (x < 2) then
  9.    y := Sqrt(Sqr(x))
  10.  else if (x > 2) and (x < 10) then
  11.    y := Abs(10 * x)
  12.  else if (x > 10) then
  13.    y := Sqr(Sin(2 * x));
  14.  
  15.  Writeln('y = ', y);
  16. end.
Новые вопросы