Напишите программу, которая выполняет реверс части массива, начиная с элемента с номером K и заканчивая элементом с номером M(включительно).
Ответы на вопрос
Ответил Аноним
0
var
i,k,m,j:integer;
a,b:array[1..10]of integer;
begin
writeln('Исходный массив:');
for i:=1 to 10 do
begin
a[i]:=random(50);
write(a[i]:3);
end;
writeln;
write('Введите k и m: ');
readln(k,m);
j:=m;
for i:=k to m do
begin
b[j]:=a[i];
j:=j-1;
end;
for i:=k to m do a[i]:=b[i];
writeln('Измененный массив:');
for i:=1 to 10 do write(a[i]:3);
end.
i,k,m,j:integer;
a,b:array[1..10]of integer;
begin
writeln('Исходный массив:');
for i:=1 to 10 do
begin
a[i]:=random(50);
write(a[i]:3);
end;
writeln;
write('Введите k и m: ');
readln(k,m);
j:=m;
for i:=k to m do
begin
b[j]:=a[i];
j:=j-1;
end;
for i:=k to m do a[i]:=b[i];
writeln('Измененный массив:');
for i:=1 to 10 do write(a[i]:3);
end.
Новые вопросы
Литература,
2 года назад
Русский язык,
2 года назад
Математика,
9 лет назад
Литература,
10 лет назад