Информатика, вопрос задал divadasha21 , 7 лет назад

Написать программу в Паскаль для вычисления и вывода значения: y = x / sin ^ 2(⁡x). Ввод значений в градусах и вывод тоже

Даю 65 баллов


restIess: Ну так а сама программа где?)
divadasha21: Задание было на другом языке, не так сначала поняла
restIess: Вывод в градусах тоже не нужен я так понимаю?
divadasha21: желательно,
divadasha21: если без вывода в градусах всеравно очень поможете
restIess: А откуда возьмётся вывод в градусах? Мы ж число получим
divadasha21: если вместо иксов поставить 45° то ответ 90°, думала в программе такой же ответ должен быть
divadasha21: но не уверенна в том что правильно решаю

Ответы на вопрос

Ответил restIess
1

//подключаем математическую библиотеку

uses math;

//объявляем 2 переменные типа double

var

x, y : double;

begin

//считываем число с клавиатуры

readln(x);

//считаем значение выражения

y := x / (power(sin(x * pi / 180.0), 2));

//выводим y на экран

writeln(y:5:2);

end.


divadasha21: Спасибо большое!
divadasha21: а как в этот код добавить область определения? ведь х не может быть равен КП где К целое число
restIess: Через if
Новые вопросы