Написать программу на языке pascal. Суть заключается в выводе чисел в стандартном виде. Например программа
program n_1;
var a:double;
begin
a:=1/100000000
end.
при исполнении выводит 1E-08. А требуется вывод 0.00000001
Решение конкретно данного случая не интересует, требуется программа для общего решения всех ситуаций.
Решение для других языков не предоставлять. Требовалось бы для других - проблем бы не было.
Ответы на вопрос
Ответил bubnowden
0
Просто пишите Writeln(a:10:5) и с помощью форматного вывода получаете число в стандартном виде. Первое число отвечает за кол-во символов для записи переменной, а второе число отвечает за число символом после запятой
Новые вопросы