Информатика, вопрос задал ivanbezbab1994 , 1 год назад

Написать программу на C#
Вычислить сумму 1/1*2/5+ 1/2*3/7+1/3*4/9+..., пока очередное слагаемое не станет меньше наперед заданного числа E.

Приложения:

Ответы на вопрос

Ответил pupkinll2016
0

Ответ:

using System;

class Program

{

static void Main(string[] args)

{

double e = 0.001; // наперед заданное число E

double sum = 0;

double term = 1;

int n = 1;

while (term >= e)

{

sum += term;

n++;

term = (double)n / (n + 4) * (double)(n - 1) / (n + 3);

}

Console.WriteLine($"Сумма ряда: {sum:F3}");

}

}

Объяснение:

В этой программе мы объявляем переменные e (наперед заданное число E), sum (сумма ряда), term (очередное слагаемое), и n (номер слагаемого). Затем мы используем цикл while, чтобы вычислить сумму ряда, пока очередное слагаемое term больше или равно заданному числу e. Внутри цикла мы увеличиваем номер слагаемого n, вычисляем очередное слагаемое term, и добавляем его к сумме ряда sum. В конце мы выводим сумму ряда с помощью метода Console.WriteLine().

Обратите внимание, что формула для вычисления очередного слагаемого ряда использует значения n, n+4, n-1, и n+3. Сначала мы делим n на n+4, а затем домножаем результат на (n-1)/(n+3). Это соответствует первым двум слагаемым в ряду. Если вам нужно вычислить больше слагаемых, вам нужно изменить это выражение.

Новые вопросы