Написать программу, которая сортирует записи в файле F по алфавиту по фамилиям.
Ответы на вопрос
Ответил Giammy
0
// PascalABC.NET
// Версия 3.4 сборка 1749 (18.08.2018)
begin
var (f, out) := (ReadAllLines('in.txt'), OpenWrite('in.txt'));
f.Select((t, i)-> (t.ToWords[0], i)).Sorted.ForEach(t -> begin Writeln(out, f[t[1]]) end);
out.Close;
end.
Файл, который использовал для проверки в приложении(совпадение с реальными именами - случайность).
Считывание и запись происходит в одном файле.
Приложения:
Новые вопросы