Информатика, вопрос задал PolinaN , 7 лет назад

Надо написать программу в паскаль, помогите пожалуйста пожалуйста пожалуйста!

Приложения:

Ответы на вопрос

Ответил fefemf10
0

var

n,i,j, sum: integer;

mas: array[1..100,1..100] of integer;

begin

sum:=0;

readln(n);

for i:=1 to n do

begin

for j:=1 to n do

read(mas[i,j]);

readln;

end;

for i:=1 to n do

inc(sum, mas[i,i]);

for i:=1 to n do

for j:=1 to n do

if (mas[i,j]>sum) then dec(mas[i,j], sum);

writeln('Вывод');

for i:=1 to n do

begin

for j:=1 to n do

write(mas[i,j], ' ');

writeln;

end;

end.

Ответил fefemf10
0
var
n,i,j, sum: integer;
mas: array[1..100,1..100] of integer;
begin
randomize;
sum:=0;
readln(n);
for i:=1 to n do
begin
for j:=1 to n do
mas[i,j]:=random(10)+1;
end;
for i:=1 to n do
inc(sum, mas[i,i]);
for i:=1 to n do
for j:=1 to n do
if (mas[i,j]>sum) then dec(mas[i,j], sum);
writeln('Вывод');
writeln('Сумма главной диагонали = ', sum);
for i:=1 to n do
begin
for j:=1 to n do
write(mas[i,j], ' ');
writeln;
end;
end.
n > 99 НЕ ВВОДИТЬ
Ответил PolinaN
0
Получилось! Спасибо большое! Как я могу отблагодарить??
Ответил fefemf10
0
Ни как, мне просто делать нечего вот и сижу на сайте втыкаю :)
Ответил PolinaN
0
Ты огромный молодец, сейчас на этом направлении можно хорошо зарабатывать)
Ответил fefemf10
0
Да, знаю я то и хочу этим заниматься, но лень иногда + реальные проекты сложней, чем эти вот задания
Новые вопросы