Информатика, вопрос задал PolinaN , 7 лет назад

Написать программу в паскаль, не получаются они у меня, помогите пожалуйста!

Приложения:

Ответы на вопрос

Ответил fefemf10
0

var

n,i,j,max,min: integer;

f1, f2: boolean;

mas: array[1..100,1..100] of integer;

begin

readln(n);

for i:=1 to n do

begin

for j:=1 to n do

read(mas[i,j]);

readln;

end;

max:=mas[1,1];

min:=mas[n,n];

for i:=2 to n do

if (mas[i,i] > max) then max:=mas[i,i];

for i:=1 to n do

if (mas[i,n-i+1] < min) then min:=mas[i,n-i+1];

writeln('Вывод');

for i:=1 to n do

for j:=1 to n do

begin

if (mas[i,j]> max) then f1:=true else f1:=false;

if (mas[i,j] < min) then f2:=true else f2:=false;

end;

if (f1) then

writeln('Полученый максимум по главной диагонали не является максимальным в матрице')

else writeln('Полученый максимум по главной диагонали является максимальным в матрице');

if (f2) then

writeln('Полученый минимум по побочной диагонали не является минимальным в матрице')

else writeln('Полученый минимум по побочной диагонали является минимальным в матрице');

end.

Ответил fefemf10
0
pastebin . com / F71G1jka перейди на этот сайт и убери прабелы из ссылки там на сайте будет код
Ответил PolinaN
0
Он почему то не правильно ответы пишет... Всегда выдаёт что является максимальным и минимальным, но это не так
Ответил fefemf10
0
Нет все так правильно, смотри там очень маленькая вероятность того что сумма главной диагонали будет меньше чем любое число из матрицы и с минимальным там точно так же
Ответил fefemf10
0
ой не сумма а сам элемент
Ответил fefemf10
0
vk . com / fefemf10 напиши мне в сообщения что-то, я тебе скрины отправлю почему так(удали из ссылки пробелы)
Новые вопросы