как написать программу на языке c++ которая находит сумму минимального нечетного числа и максимального четного числа
Ответы на вопрос
Код программы:
#include <iostream>
using namespace std;
int main()
{
int *mas, n, sum, max, min;
bool f_max= false, f_min = false;
cout<<"Введите количество элементов в массиве"<<endl;
cin >> n;
mas = new int(n);
cout<<"Введите элементы"<<endl;
for (int i = 0; i < n; i++)
cin >> mas[i];
cout<<"Ваш массив: "<<endl;
for (int i = 0; i < n; i++)
cout << mas[i] <<' ';
max = min = mas[0];
for (int i = 0; i < n; i++){
if (mas[i] % 2 == 0){
if (max <= mas[i]){
max = mas[i];
f_max = true;
}
}
else{
if (min >= mas[i]){
min = mas[i];
f_min = true;
}
}
}
if (f_min == false)
min = 0;
if (f_max == false)
max = 0;
sum = max + min;
cout<<"\nСумма = "<< sum<<endl;
return 0;
}