как написать программу для паскаля которая считает площадь квадрата??????
Ответы на вопрос
Ответил ranDAt
0
Квадрат вписан в круг.
Нужно написать програмку, которая считает площадь окружности, если ввести сторону квадрата
У меня вышла формула :
S окр = ((a^2)/2) * (P(число пи)-2) - Площадь круга минус площадь квадрата
вот код :
Program Okruzhnost;
Var
x,y: real;
S: real;
Procedure RectS(a,b: real; Var S:real);
Begin
S := (((sqr(x))/2) * (pi-2));
end;
Begin
WriteLn('Введите сторону квадрата');
ReadLn(x,y);
RectS(x,y,S);
WriteLn('Площадь окружноси равна',S);
end.
Нужно написать програмку, которая считает площадь окружности, если ввести сторону квадрата
У меня вышла формула :
S окр = ((a^2)/2) * (P(число пи)-2) - Площадь круга минус площадь квадрата
вот код :
Program Okruzhnost;
Var
x,y: real;
S: real;
Procedure RectS(a,b: real; Var S:real);
Begin
S := (((sqr(x))/2) * (pi-2));
end;
Begin
WriteLn('Введите сторону квадрата');
ReadLn(x,y);
RectS(x,y,S);
WriteLn('Площадь окружноси равна',S);
end.
Приложения:

Ответил ZaharovVasya
0
Var a,S:integer;
Begin
writeln('введите сторону квадрата');
readln(a);
S:=a*a;
writeln('Площадь = ',S);
readln;
end.
Begin
writeln('введите сторону квадрата');
readln(a);
S:=a*a;
writeln('Площадь = ',S);
readln;
end.
Приложения:

Новые вопросы
Другие предметы,
2 года назад
Английский язык,
2 года назад
Обществознание,
10 лет назад
Информатика,
10 лет назад