Информатика, вопрос задал Natali2512 , 10 лет назад

составьте программу которая позволяет закодировать строку путем замены всех звонких согласных на соответствующие глухие, а глухих на звонкие

Ответы на вопрос

Ответил yuliagal
0
const
  s: array [1..6] of char= ('б','в','г','д','ж','з');
  d: array [1..6] of char= ('п','ф','к','т','ш','с');

var
  c: string;
  i,j: integer;

begin
  readln(c);
  for i:= 1 to length(c) do
    for j:= 1 to 6 do
      if d[j]=c[i] then c[i]:= s[j]
      else
        if s[j]=c[i] then c[i]:= d[j];
  writeln(c)
end.
Новые вопросы