Изменение
элементов массива
Дан массив из N положительных элементов, больших 1
(2<=N<=100).
После каждого элемента вставить его минимальный делитель
больший 1.
Формат входных данных:
На входе подаются в первой строке N - число элементов массива
Вторая строка содержит N чисел - значения элементов массива
Формат выходных данных: Выведите результирующий массив в строку
Пример:
Ввод
5
43 50 76 84 100
Вывод
43 43 50 2 76 2 84 2 100 2
Ответы на вопрос
Ответил kage1998
0
program gt;
label 1,2;
var a,b:array[1..1000]of integer;
n,i,l,j:integer;
begin
read(n);
for i:=1 to n do
begin
read(a[i]);
l:=round(sqrt(a[i]));
for j:=2 to l do
begin
if(a[i] mod j=0)then goto 1;
end;
b[i]:=a[i];
goto 2;
1:
b[i]:=j;
2:
end;
for i:=1 to n do
begin
write(a[i],' ',b[i],' ');
end;
end.
label 1,2;
var a,b:array[1..1000]of integer;
n,i,l,j:integer;
begin
read(n);
for i:=1 to n do
begin
read(a[i]);
l:=round(sqrt(a[i]));
for j:=2 to l do
begin
if(a[i] mod j=0)then goto 1;
end;
b[i]:=a[i];
goto 2;
1:
b[i]:=j;
2:
end;
for i:=1 to n do
begin
write(a[i],' ',b[i],' ');
end;
end.
Новые вопросы
Қазақ тiлi,
2 года назад
Українська мова,
2 года назад
Математика,
10 лет назад
Математика,
10 лет назад
География,
10 лет назад