ДАЮ 80 БАЛЛОВ ПОМОГИТЕ ПРОШУ
Составить программу на языке Паскаль для решения следующей задачи:
Дан одномерный массив. Замените все отрицательные элементы массива их квадратами, положительные элементы оставьте без изменения. Входные данные для размерности массива и значения элементов массива задайте самостоятельно.
На проверку нужно прислать текст кода программы, результат работы кода в виде скриншота окна программы с отображением кода и полученного результата. Программная реализация обязательна!
Ответы на вопрос
Ответил dzhanelinavi
3
Ответ:
Var a:array[1..10] of integer;
l,m,n :integer;
begin
for l:=1 to 10 do
a[l]:=Random(30)-10;
writeln('Массив1');
for l:=1 to 10 do
write( a[l],' ');
writeln;
for l:=1 to 10 do
if a[l] <0 then a[l]:=sqr(a[l]);
writeln('Массив2');
for l:=1 to 10 do
write( a[l],' ');
writeln;
end.
Новые вопросы
Другие предметы,
2 года назад
Английский язык,
2 года назад
Литература,
6 лет назад
Математика,
6 лет назад
Математика,
8 лет назад