Информатика, вопрос задал mif54 , 6 лет назад

ДАЮ 25 БАЛЛОВ
составить программу. на языке программирования паскаль. задача: Осёл может принести груз равной половине своего веса. вес осла- m кг. в первый день на осла нагрузили а кг, а каждый следующий день увеличивали вес груза на 1 кг. сколько дней сможет работать осел, и какой суммарный груз он перевезет за это время?
срочно пж!!!!​

Ответы на вопрос

Ответил ussrex
1

Ответ:

program osel;

uses crt;

var m, a, d, g:Real;

begin

clrscr;

Write('Масса осла, кг: ');

readln(m);

Write('Масса груза в первый день, кг: ');

readln(a);

if a<=m/2 then begin

g:=a; d:=1;

while (a+1)<=m/2 do begin

d:=d+1;

a:=a+1;

g:=g+a

end; write('Осёл проработает ',d,' дней и перенесёт ',g,' кг груза') end

else write('С таким грузом осёл работать не сможет!');

readln;

end.

Новые вопросы