Информатика, вопрос задал Anastasiya212121 , 7 лет назад

Даны три целых числа. Найдите наибольшее из них(программа должна вывести ровно одно целое число). Какое наименьшее число операторов сравнения потребовалось для решения этой задачи?
Задача для прописания в 1с (новичок)

Ответы на вопрос

Ответил Аноним
0

Ответ:

Программа на питоне:

def math(first,second,third):

       if first > second and first > third:

           print(first)

       elif second > first and second > third:

           print(second)

       elif third > second and third > first:

           print(third)

       else:

           print("Некоторые из чисел (или все) равны")

Операторов сравнения - 6

Объяснение:

в Интерактивном интерпретаторе (IDLE) Создаешь новый файл и пишешь там этот код. После запуска пишешь команду math() и внутри через запятую указываешь числа. Пример: math(1,2,3).

В случае если числа равны - выводится строка "Некоторые из чисел (или все) равны"

Новые вопросы