1В результате выполнения программы
program my_klass;
var
a:integer;
begin
a:=25+24*2;
writeln ('улыбок');
end.
мы увидим на экране:
а) 73 улыбок; в) 'улыбок'; б) улыбок; г) улыбок73
2Чему будет равно значение переменной sum, после выполнения данной программы, если n = 389; n = 725; n = 345
Program pr1;
var sum,n:integer;
begin
writeln('Введите трехзначное число');
readln(n);
sum:=(n div 10)+(n div 15 mod 10)+(n div 6);
writeln('Сумма цифр числа = ',sum);
end.
3Какие из операторов присваивания не будет работать в программе с разделом описания переменных:
Var
n:integer;
Выберите вариант ответа:
1) 25:=n; 2) n:=2.5; 3) n=25; 4) n:=25
4Найти значение выражения:
55 div 10 + 14 =
205 mod 100 + 1 =
(32 mod 4 + 1) * 24 =
5Чему будет равно значение переменной sum, после выполнения данной программы, если X =479.
Program SumCifr;
Var X, Sum: integer;
Begin
Write(‘Введите трехзначное число: ');
ReadLn(X);
Sum:=5;
Sum:=Sum + X mod 10;
X:=X div 5;
Sum:=Sum + X mod 10;
X:=X div 4;
Sum:=Sum + X;
Write (' цифр = ',Sum)
End.
Ответы на вопрос
Ответил HappyCoder
0
Ответ:
1) улыбок(б)
2)
Для N 389: 107
Для N 725: 200
Для N 345: 97
3) Не будут работать 1 и 2
4)
55 div 10 + 14 = 19
205 mod 100 + 1 = 6
(32 mod 4 + 1) * 24 = 24
5) 42
Новые вопросы