Информатика, вопрос задал 0lolosha , 10 лет назад

1. Составьте программу для определения суммы денег, получаемой авиакомпанией от продажи билетов на рейс из Лондона в Нью-Йорк, если в самолете три четверти пассажиров имеют билеты первого класса, стоимостью Х рублей за каждый. Остальные пассажиры имеют билеты второго класса, которые дешевле на 20%
2.Составьте программу определения стоимости набора конфет, в которой находятся следущие сорта:
Наименование:            Количество:            Цена,руб:
Красная шапочка         500 г                      k
Алые паруса                200 г                      a
Воронежские               100 г                       b
Чародейка                   250 г                       m

Ответы на вопрос

Ответил uropb123
0
program avia;
uses crt;
var
p:integer;
s,s2,pr,ch3:real;
begin
writeln('Стоимость билета 1 класса: ');
read(s);
writeln('Общее количество пассажиров: ');
read(p);
ch3:=(3*(p/4));// 3 четверти пассажиров
pr:=(s/100)*20;// 20% от стоимости
s2:=(ch3*s)+((p/4)*pr);
writeln('Всего заработает за рейс: ',s2);
end.


program cena;
uses crt;
var
k,a,b,m,obc:real;
begin
writeln('Цена за конфеты "Красная шапочка": ');
read(k);
writeln('Цена за конфеты "Алые паруса": ');
read(a);
writeln('Цена за конфеты "Воронежские": ');
read(b);
writeln('Цена за конфеты "Чародейка": ');
read(m);


 obc:=0.5*k+0.2*a+0.1*b+0.25*m;
 writeln('Всего ',obc,' руб.')
end.





Новые вопросы