Информатика, вопрос задал Dan2005rub , 2 года назад

Здравствуйте. Срочно нужна помощь!
Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число — минимальное число, кратное 6 (в тетради письменно)

Ответы на вопрос

Ответил UBSilver
1

Ответ:

Объяснение:

program prog;

var  

x,i,n,tmp:integer;

arr:array [1..1000] of integer;

begin

Writeln('Enter n: ');

readln(n);

x:=30000;

Writeln('Enter numbers: ');

for i:=1 to n do readln(arr[i]);

for i:=1 to n do

begin

tmp:=arr[i] mod 6;

if (tmp=0) and (arr[i]<x) then x:=arr[i];

end;

writeln(x);

end.

Новые вопросы