Информатика, вопрос задал Хенкок1 , 10 лет назад

Здравствуйте) Помогите составить программу вычисления значений функции в VBA, заданных несколькими условиями с использованием условного оператора If.... Then.... Else... , никак не даётся(((

Приложения:

Ответы на вопрос

Ответил Sky09
0
uses crt;
var F:real;
    x,a:integer;
begin
     write('x:'); readln(x);
     write('a:'); readln(a);
     if (x>=0) and ((a>-1)or(a<2)) then f:=sqrt(x-sin(a))
     else
         if ((x>1)or(x<=3)) and (a<0) then f:=power(ln(13),3)-sqr(cos(x))
         else
             f:=(1+abs(x+a))/(ln(x-a));
     writeln(F);
end.
Ответил Хенкок1
0
Ничего страшного=)
Ответил Sky09
0
Нет, не смогу, я не знаю VBA
Ответил Хенкок1
0
спасибо и на этом=)
Ответил Sky09
0
Да было бы за что...
Новые вопросы