Информатика, вопрос задал p6fwb8888b , 1 год назад

Здравствуйте, помогите пожалуйста, напишите в питоне через цикл while Дано натуральное число M. Написать программу для вычисления суммы вида: 45+42+39+...+M.

Ответы на вопрос

Ответил betman134
2

M = 0  # любое число

result = 0

step = 45

while step > M:

   result = result + step

   step = step - 3

result = result + M

print(result)

Подразумевается, что М всегда является конечным элементом, даже если step оказался меньше M. То есть в конце концов М всегда прибавляется к сумме.

Если же М должен прибавляться только когда step==M, тогда в условии цикла надо поставить >=, а строку result = result + M стереть.


betman134: Программа также работает и с отрицательным М. Если я не верно понял условие, напиши - я отредактирую ответ
Новые вопросы