Информатика, вопрос задал almaz1477 , 7 лет назад

Здравствуйте! Помогите, пожалуйста, написать программу нахождения большего из трех чисел, переменнае назвать в соответствии с инициалами К L A

Ответы на вопрос

Ответил Browze
0

c++/gcc 730

#include <iostream>

#include <algorithm>


int main()

{

   int K, L, A;

   std::cin >> K >> L >> A;


   std::cout << std::max({K, L, A}) << std::endl;

   return 0;

}


Приложения:
Ответил almaz1477
0
а как будет с рандомным заполнением?
Ответил Browze
0
#include
#include
int main()
{
std::default_random_engine generator(std::random_device{}());
std::uniform_int_distribution distribution(1, 500);
int K{distribution(generator)}, L{distribution(generator)}, M{distribution(generator)};
std::cout << K << std::endl
<< L << std::endl
<< M << std::endl;
return 0;
}
Ответил Browze
0
Компилировать с флагом -std=C++11, если компилятору нужно принудительно установить это. Подобные генерации были добавлены в стандарте C++. Разумеется, можно сделать и через std::rand() из cstdlib, если для Вас это будет непосильно.
Ответил almaz1477
0
огромное спасибо!!!
Ответил Browze
0
#include iostream
#include random
В кавычках. Не заметил, что редактор удалил
Новые вопросы