Информатика, вопрос задал rashidiyosiparn , 2 года назад

здраствуйте помогите решить задачу на Python
Аве, Цезарь ️
На вход программе подается строка текста на английском языке, в которой нужно зашифровать все слова. Каждое слово строки следует зашифровать с помощью шифра Цезаря (циклического сдвига на длину этого слова). Строчные буквы при этом остаются строчными, а прописные – прописными.

Формат входных данных
На вход программе подается строка текста на английском языке.

Формат выходных данных
Программа должна вывести зашифрованный текст в соответствии с условием задачи.

Примечание. Символы, не являющиеся английскими буквами, не изменяются.

Sample Input 1:

Day, mice. "Year" is a mistake!
Sample Output 1:

Gdb, qmgi. "Ciev" ku b tpzahrl!
Sample Input 2:

my name is Python!
Sample Output 2:

oa reqi ku Veznut!


rasulislyamgali: Напиши в телеграм @rasulislyamgali. ps: здесь оставить ответ не хочу, чтобы не мешать авторам курса на степик.

Ответы на вопрос

Ответил brykovvita173
3

Ответ:

alphavit_engB = 'ABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTUVWXYZ'

alphavit_engM = 'abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyz'

li = input().split()

itog = ''

for i in li:

   z = 0

   for j in i:

       if j.isalpha() == True:

           z += 1

   for j in i:

       mestoB = alphavit_engB.find(j)            #АВЕ, ЦЕЗАРЬ      

       mestoM = alphavit_engM.find(j)

       new_mestoB = mestoB + z

       new_mestoM = mestoM + z

       if j.isalpha() == True:

           if j == j.upper():

               itog += alphavit_engB[new_mestoB]

           elif j == j.lower():

               itog += alphavit_engM[new_mestoM]

       else:

           itog += j  

   itog += ' '

print(itog)

Объяснение:

Новые вопросы