Информатика, вопрос задал yestopacc , 2 года назад

Заводные жуки в квадрате
Написать программу на python, отвечающую этим требованиям
Есть такая математическая задача, в которой жуки двигаются из четырех углов квадрата всегда в направлении соседнего жука с одинаковой скоростью и в одном направлении. Нужно найти расстояние, которое пройдет каждый жук до встречи в центре квадрата.
Задача решается легко, если перейти в систему отсчета одного из жуков и понять, какое расстояние ему нужно пройти. Хотя траектория движения жуков довольно сложная — это логарифмическая спираль.
Немного изменим условие.
PIC
У нас будут двигаться механические жуки. Такой жук движется одну секунду по своей стороне квадрата, затем мгновенно определяет положение ближайшего спереди и справа жука, поворачивает к нему и снова движется одну секунду по стороне уже меньшего квадрата. Так продолжается, пока сторона квадрата, по которой движется жук, не станет меньше или равна расстоянию, которое он должен пройти за секунду.
Теперь траектория жука — это ломаная линия.
Найдите количество поворотов, которые пришлось сделать каждому жуку.
Формат ввода
На отдельных строках вводятся 2 вещественных числа: сторона квадрата и скорость жука в секунду.
Формат вывода
Целое число — количество поворотов жука.
Пример
Ввод Вывод
2 3
1

Примечания
Поскольку в этой задаче нужно сравнивать вещественные числа, давайте это делать с точностью до сотых. abs(x − y) <= 0.01

Ответы на вопрос

Ответил pihta24
5

Ответ:

from math import sqrt

dist = float(input())

speed = float(input())

i = 0

while dist - speed > 0.01:

   dist = sqrt((dist - speed) ** 2 + speed ** 2)

   i += 1

print(i)

Объяснение:

Новые вопросы