Заранее спасибо :3
Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область.
Входные данные
Входная строка содержит два вещественных числа – координаты точки на плоскости (сначала x -координата, затем – y -координата).
Выходные данные
Программа должна вывести слово 'YES', если точка попала в заштрихованную область, и слово 'NO', если не попала.
В ПАСКАЛЕ
Приложения:

Ответы на вопрос
Ответил petyaGavrikov
0
var x,y : real;
begin
write('x = '); readln(x);
write('y = '); readln(y);
if (y>1-x)and(x<1)and((y>2*x*x)or(y<2*x*x)and(x>0))
then writeln('YES') else writeln('NO')
end.
Пример:
x = 0.75
y = 1
YES
begin
write('x = '); readln(x);
write('y = '); readln(y);
if (y>1-x)and(x<1)and((y>2*x*x)or(y<2*x*x)and(x>0))
then writeln('YES') else writeln('NO')
end.
Пример:
x = 0.75
y = 1
YES
Новые вопросы