Информатика, вопрос задал starkina2405 , 1 год назад

Запишем на Языке Паскаль алгоритм вычисления степени с натуральным показателем n для любого существенного числа a
СРОЧНО❤❤❤

Приложения:

Gerays13: могу только на питоне
starkina2405: Нет,мне нужно на Паскале

Ответы на вопрос

Ответил Infasotkabtw
1

Ответ:

var

 a, i, n, sum: integer;

 

begin

 read(a, n);

 sum := 1;

 for i := 1 to n do sum := sum * a;

 writeln(sum);

end.

Ответил stepanrefn
2

немного покрасивее сделал

////////////////////////////////////////////

program vozvedenieVstepen;

var  a, i, n, sum: integer;

begin

 write('число = ');

 readln(a);

 write('степень = ');

 readln(n);

 sum:=1;

 for i:=1 to n do

   sum:=sum*a;

 writeln(sum);

end.


starkina2405: Спасибо!)Вы же уверены в правильности этого ответа?
stepanrefn: Да, я проверял работоспособность в среде PascalABCNET
Новые вопросы