Занесите информацию о 10-ти европейских странах в массивы. Найдите максимальную плотность населения. Страны: Россия', 'США', 'Греция', 'КНР', 'Турция', 'Германия', 'Испания', 'Колумбия', 'Бразилия', 'Египет.
Написать программу на Паскаль
Ответы на вопрос
Ответ:
var
strana: array [1..10] of string = ('Россия','США','Греция','КНР','Турция','Германия','Испания','Колумбия','Бразилия','Египет'); //названия стран
area: array [1..10] of real; //площади стран
nas: array [1..10] of integer; //населения стран
i, max_i: integer;
max_pl: real;
begin
for i := 1 to 10 do
begin
Write('Введите площадь страны (в кв.км.) ', strana[i], ': '); ReadLn(area[i]);
Write('Введите население страны (в чел.) ', strana[i], ': '); ReadLn(nas[i]);
if (nas[i] / area[i] > max_pl) then
begin
max_i := i;
max_pl := nas[i] / area[i];
end;
end;
WriteLn('Максимальная плотность населения в стране - ', strana[max_i], '. И равна ', max_pl, 'чел/кв.км.');
end.
Объяснение: