Заданы два целых числа a и b. Составьте программу, определяющую, сколько целых чисел, которые одновременно удовлетворяют двум неравенствам x>a и x<b
Ответы на вопрос
Ответил elenaklon
0
var a,b:integer;
begin
readln (a,b);
if a<b then write (b-1-a) else write(0)
end.
Ответил Аноним
0
Что это такое?
Ответил elenaklon
0
Например: a=5 и b=15. Значит 5
Ответил elenaklon
0
Значит 5
Ответил Аноним
0
Ввод: a ^ b С/П.
- x>=0 05 0 С/П /-/ 1 - С/П
Согласен, отрицательный результат противоречит условию, исправил. Благодарю за замечание, был невнимателен.
Смысл кода такой:
X = a; Y = b;
X -= Y; Если не (X >= 0), переход на 05; X = 0; Стоп; [05] Смена знака; Y = X, X = 1; X -= Y; Стоп. На индикаторе X.
Рад, что мои решения кому-то интересны.
Новые вопросы
Русский язык,
2 года назад
Английский язык,
2 года назад
Геометрия,
7 лет назад
Геометрия,
7 лет назад
Геометрия,
9 лет назад
Математика,
9 лет назад