задано двухзначное число. составить программу, которая отвечает на вопрос, правда ли, что все его цифры чётные
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1540 от 16.09.2017
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('Введите двухзначное натуральное число:');
if (n div 10).IsEven and (n mod 10).IsEven then Writeln('Да')
else Writeln('Нет')
end.
Пример
Введите двухзначное натуральное число: 28
Да
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('Введите двухзначное натуральное число:');
if (n div 10).IsEven and (n mod 10).IsEven then Writeln('Да')
else Writeln('Нет')
end.
Пример
Введите двухзначное натуральное число: 28
Да
Ответил vunderkid
0
program oddn;
var
a,b,c: integer;
begin
readln(c);
a:=c div 10;
b:=c - a*10;
if (a and 1=0) and (b and 1=0) then
writeln('все цифры четные')
else
writeln('есть нечетные цифры');
end.
var
a,b,c: integer;
begin
readln(c);
a:=c div 10;
b:=c - a*10;
if (a and 1=0) and (b and 1=0) then
writeln('все цифры четные')
else
writeln('есть нечетные цифры');
end.
Новые вопросы
История,
2 года назад
Русский язык,
2 года назад
Биология,
8 лет назад
Обществознание,
8 лет назад
Литература,
9 лет назад