Задано целое число М. Напишите программу, которая находит сумму цифр заданного числа.
Формат входных данных
Во входных данных записано одно целое число N (-2 * 10° < N < 2 * 10°).
Формат выходных данных
Выведите сумму цифр заданного числа.
Паскаль
pofgerbsad:
Задано целое число N
Ответы на вопрос
Ответил Artur617
0
program SumOfDigits;
var
N, sum, digit: integer;
begin
sum := 0;
readln(N);
N := abs(N); // переводим число в положительную форму
while N > 0 do
begin
digit := N mod 10; // получаем последнюю цифру числа
sum := sum + digit; // добавляем ее к сумме
N := N div 10; // отбрасываем последнюю цифру
end;
writeln(sum);
end.
Новые вопросы