Информатика, вопрос задал masha123449 , 7 лет назад

Заданной двузначное число. Составьте программу с помощью которой определите произведения квадратов цифр этого числа( на языке pascal)

Ответы на вопрос

Ответил flickyoff
0

Ответ:

Язык: Pascal

program z1;

var a, x, y, b: integer;

begin

read(a);

x:= a div 10;

y:= a mod 10;

x:= sqr(x);

y:= sqr(y);

b:= x*y;

writeln('Квадрат первой цифры числа = ', x);

writeln('Квадрат второй цифры числа = ', y);

writeln('Произведение квадратов чисел = ', b);

end.

Объяснение:

Ответил flickyoff
0
если вывод каждого квадрата не нужен, то можете убрать первый и второй writeln
Новые вопросы