Задание в паскале нужно написать программу:
Дан двумерный массив случайных чисел от -05 до 14 из 5 строк и 5 столбцов.Вывести на экран первоначальные значения элементов массива в виде матрицы. Поменять местами первый и второй столбец.Вывести на экран новые значения элементов массива в виде матрицы
Кто знает,помогите, с меня презент)
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('*** Исходный массив ***');
var a:=MatrRandom(5,5,-5,14);
a.Println(4); Writeln(4*a.ColCount*'-');
a.SwapCols(0,1);
Writeln('*** Результирующий массив ***');
a.Println(4);
end.
Пример
*** Исходный массив ***
12 10 7 -2 5
14 0 7 1 14
0 -1 7 5 7
-5 -5 -4 -4 9
7 8 -5 12 12
--------------------
*** Результирующий массив ***
10 12 7 -2 5
0 14 7 1 14
-1 0 7 5 7
-5 -5 -4 -4 9
8 7 -5 12 12
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('*** Исходный массив ***');
var a:=MatrRandom(5,5,-5,14);
a.Println(4); Writeln(4*a.ColCount*'-');
a.SwapCols(0,1);
Writeln('*** Результирующий массив ***');
a.Println(4);
end.
Пример
*** Исходный массив ***
12 10 7 -2 5
14 0 7 1 14
0 -1 7 5 7
-5 -5 -4 -4 9
7 8 -5 12 12
--------------------
*** Результирующий массив ***
10 12 7 -2 5
0 14 7 1 14
-1 0 7 5 7
-5 -5 -4 -4 9
8 7 -5 12 12
Новые вопросы